Tab Mix Plus

Official Home of TMP
It is currently Tue Mar 28, 2017 2:49 pm

All times are UTC - 6 hours [ DST ]




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 35 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Test Build
PostPosted: Sat Nov 12, 2011 2:51 am 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9105
Tab Mix Plus v0.3.8.7 is coming soon, and i am already working on the next version.

This development build include 2 major changes:
  1. Implementing smooth scroll when there are many tabs (overflow) in single and multi-row.
  2. Code cleanup in preparation of dropping support for the ancient Firefox version 3.5, 3.6.

This build is for testing and as such don't have an automatic update, you can install it from here.
In order to go back to regular Development build channel install this.
For official Tabmix version go to here

_________________
Tab Mix Plus 0.5.0.2
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sat Nov 12, 2011 3:54 pm 
Offline

Joined: Fri Dec 23, 2005 11:17 pm
Posts: 80
Location: CA
When holding ctrl+clicking a link, no new tab opens and I see:

Error: target is not defined
Source File: chrome://tabmixplus/content/links/contentLinks.js
Line: 1360

in the error console. Middle clicking works. I have lots of other extensions and have not done any testing to check if this is really a problem with the TMP test build or something else.


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sat Nov 12, 2011 4:01 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
Aha! I had the same error/diff. line with dev.build. Something isn't right there. In my case, i get some random links opening twice - in the same tab AND in a new tab on simple Rclick (all set to open in new tab). I've been dealing with this for a while now and can't figure what might be causing this. Thought it was a conflict and it seems like Linkification (1.3.9) and/or Textarea Cache (0.8.5) might be the culprit but then if i disable them, it would still be happening even though not as often. Once, i got this error but usually see no errors:

Error: target.ownerDocument.location is null
Source file: chrome://tabmixplus/content/links/contentLinks.js
Line: 188
==========
let href = target.ownerDocument.location.href;

(viewtopic.php?p=54011#p54011)

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sat Nov 12, 2011 4:31 pm 
Offline

Joined: Fri Dec 23, 2005 11:17 pm
Posts: 80
Location: CA
It seems to have something to do with 'Force to open in new tabs:' setting (in the Links tab in TMP options.) The only time I have a problem is if I have it set to 'Links to other sites'. Links to other sites open fine, but links to the same domain throw the error and don't open anything. I still haven't checked it this is truly a TMP problem or other extensions/profile problem.

edit: A good example is makondo's post above this one. The link to the other page of this forum (bug report) won't work, but the link to the userstyles in the signature work.


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sat Nov 12, 2011 5:38 pm 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9105
Chris000001 wrote:
When holding ctrl+clicking a link, no new tab opens and I see:

Error: target is not defined
Source File: chrome://tabmixplus/content/links/contentLinks.js
Line: 1360

in the error console. Middle clicking works. I have lots of other extensions and have not done any testing to check if this is really a problem with the TMP test build or something else.


thank you for the report Chris,
i was just missed one place with target, i was replaced it with linkNode

makondo,
The problem that you reported already fixed in the dev-build, do you see any error in this Test build ?

_________________
Tab Mix Plus 0.5.0.2
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sat Nov 12, 2011 5:51 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
No, didn't see any yet. But i still have the problem: some links, randomly, open twice (in the same tab and new tab) or simply open in the same tab.

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sun Nov 13, 2011 10:25 am 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9105
makondo wrote:
No, didn't see any yet. But i still have the problem: some links, randomly, open twice (in the same tab and new tab) or simply open in the same tab.


can you give some examples ?

_________________
Tab Mix Plus 0.5.0.2
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sun Nov 13, 2011 12:28 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
Go to the Members list on this forum and start clicking names.
My settings: everything suppose to open in new background tabs at the end. Tabs are not locked (wish they were but in order to use my Drag Link ext., i had to ucheck that option, remember?).
Now, as you click, some link - always random - will either open twice, in the current tab AND new tab, or will simply open in the same tab.
For the record, this happens with Link Drag disabled.

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sun Nov 13, 2011 1:32 pm 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9105
i CAN'T reproduce. does it happen in clean profile ?

_________________
Tab Mix Plus 0.5.0.2
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sun Nov 13, 2011 1:44 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
I don't remember now. I'm in the middle of doing something here, will test again a bit later today.
Here's the (one of the) original post: viewtopic.php?p=53769#p53769

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Sun Nov 13, 2011 7:27 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
Tried a profile with ACR, Stylish and TMP only - worked all right. But that's just my point. I can't find what causes it. Apparently a conflict. I will have to make a new profile and install all 30+ exts. one by one. Will see what i can find (i just don't see what any of my exts. can possibly have to do with links/tabs opening. Linkification and Drag Link could have but when disabled, i still get the prob).
I also still get blank tab for .xpi. Just go to AMO, click on any ext. Install button and here comes a blank tab.

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 1:45 am 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9105
makondo,
In AMO even if i turn off Tabmix option to prevent blank tabs on downloads AMO doesn't open new tab for me.

_________________
Tab Mix Plus 0.5.0.2
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 12:32 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
Thanks .... Image

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 6:26 pm 
Offline

Joined: Mon Nov 14, 2011 6:23 pm
Posts: 10
help tab_mix_plus-test.build.111112a.xpi
how to make the tabs did not move to the left side at the closing? I am tired ..... : (
because of this bug in mozile I'm on a version of TabMixPlus {0.3.8.6pre.110402b} as there are tabs behave normally

http://www.youtube.com/watch?v=zhZgC9ginZc

another said that if the mouse wheel to scroll the tabs are not thumbed through a 1 to 3 ... and not uniformly.
with a version of TabMixPlus {0.3.8.6pre.110402b} they thumbed through on a panel and flat and does not go into all the clutches in the left side (if you remove the mouse from the tab bar it returns to the right) as it does with new versions (if your open tabs 50 then tab to the tab bar goes to the left)
this is a bug or mozily setting that can be disabled? and still go to the left tab when closing is completely crushed one ... though in fact they can be much more


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 7:40 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
^ goog translate, i'm guessing ... Image

1. When closing tab, focus on last (don't know what the issue is though... it doesn't? or is that what the poster wants?)
http://tmp.garyr.net/help/#Events_-_Tab_Closing

2. Something about scrolling the tabbar? Post your guesses, i'm at lost here.
Multirow? tab preview panel (Ctrl+tab)?
http://tmp.garyr.net/help/#Display_-_Tab_bar

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 8:46 pm 
Offline

Joined: Mon Nov 14, 2011 6:23 pm
Posts: 10
Google yes but I do not know where to write ... writing on Russian forums or who did not help: (
http://www.youtube.com/watch?v=j7-dyy0-HHA
1) tab not move uniformly by scrolling the mouse wheel
2) when you close the tab goes to the left on the video it shows how the
the second video with the old version is not and it is very good:)
http://www.youtube.com/watch?v=l1g5N_Ds_H8
1 and
http://tmp.garyr.net/help/#Display_-_Tab_bar
Scrollable without buttons
2 and
http://tmp.garyr.net/help/#Events_-_Tab_Closing
Closing current tab
Left tab

just tried to put a new version (tried all newer than TabMixPlus {0.3.8.6pre.110402b}) on a clean profile did not help ... with TabMixPlus {0.3.8.6pre.110402b} such glitches do not.


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 8:54 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
1. Smooth scrolling is on onemen ToDo list, i believe.

Sorry, i don't understand the rest. Can you post in russian here?

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 9:05 pm 
Offline

Joined: Mon Nov 14, 2011 6:23 pm
Posts: 10
yes I can.:)
1) то есть один щелчок колёсика мыши = 1 вкладка. в новой версии по 3 или по 2 вкладки меняются, если крутить колесо мыши, причём это происходит не равномерно и с ускорением. просто посмотрите видео и сравните как отличается поведение вкладок если их прокручивать колесом мыши.
2) на видео очень хорошо видно как все вкладки передвигаются в левую сторону (в старой версии такова нет). я же даже место желтым светом выделил что бы было видно...
in English just in case
1) that is one click of the mouse wheel = 1 tab. The new version of 3 or 2 tabs change when the mouse wheel to turn, and it is not uniformly and with acceleration. just watch the video and compare how different is the behavior of tabs when they scroll the mouse wheel.
2) the video is very well seen as all the tabs move to the left (in the old version is not). I also place a yellow light even identified that would be seen ...
in English just in case


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 9:17 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7447
Location: Rocky Mountains
Sorry, i still don't get it. Are you talking about animations ('tabs moving' - that's Fx new feature)? You can disable animation: http://tmp.garyr.net/help/#Events_-_Tab_Features

The scrolling - if i understand correctly, used to be one tab at a time and now it scrolls 2-3 tabs at a time? Try re-setting that option to, let's say, multirow and back to scrollable without buttons. Also, i see you're using an ext. like Colorful Tabs? Disable it and see if you still have problems.

_________________
How to post
Troubleshooting
————— ••• ——————
I'm NOT a TMP developer ◆ Win10 ♦ WaterfoxMy forum style
TMP latest dev.build


Top
 Profile  
 
 Post subject: Re: Test Build
PostPosted: Mon Nov 14, 2011 9:27 pm 
Offline

Joined: Mon Nov 14, 2011 6:23 pm
Posts: 10
2) and another movement of the tabs on the left side at the far right tab closure is a clean browser with no extensions .. maybe this feature in new versions of the browser but I do not like and just way. TabMixPlus 0.3.8.6pre.110402b helps get rid of it. but can this option if this option can be disabled?
"You can disable animation" now try but I do not think that will help. because it is already disabled.
watch the video. top right corner, highlighted in yellow ... Is there not be seen as closing the right tab, all tabs are moving to the left. Although I have 30 tabs open ... how to explain .... : (
1) yes it is. but does it also does not exactly and precisely. I badly recorded video?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 35 posts ]  Go to page 1, 2  Next

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group