Tab Mix Plus

Official Home of TMP
It is currently Sat Nov 18, 2017 8:27 pm

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 461 posts ]  Go to page Previous  1 ... 20, 21, 22, 23, 24  Next
Author Message
PostPosted: Sat Nov 04, 2017 2:36 am 
Offline

Joined: Tue Sep 06, 2011 2:18 am
Posts: 22
Yeah, there is a bit of confusion with the versions. :)


Top
 Profile  
 
PostPosted: Sat Nov 04, 2017 1:28 pm 
Offline
Admin
User avatar

Joined: Thu Aug 04, 2005 1:12 pm
Posts: 9240
makondo wrote:
onemen needs to update his sig. The latest dev.build is 0.5.0.5pre.171027a1. I'm sure he will once he gets a chance.


FIXED

_________________
Tab Mix Plus 0.5.0.4
Latest Dev-Build
Forum RSS, Troubleshooting


Top
 Profile  
 
PostPosted: Sat Nov 04, 2017 4:04 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7716
Location: Rocky Mountains
Image

_________________
•► How to post
•► Troubleshooting
————— ••• ——————
TMP latest dev.build
Win10 ♦ Waterfox
◆ I'm NOT a TMP developer ◆


Top
 Profile  
 
PostPosted: Sat Nov 04, 2017 4:52 pm 
Offline

Joined: Fri Aug 14, 2015 8:57 am
Posts: 14
Today Nightly broke multi-row again. Just reporting.

Edit:
I can't select tabs with mouse click, too.


Top
 Profile  
 
PostPosted: Sat Nov 04, 2017 7:25 pm 
Offline

Joined: Tue Sep 06, 2011 2:18 am
Posts: 22
I can't get it to work on Firefox 57 Beta 14. It is saying that it is not compatible.
Do I need a different Firefox version? Also, which link gives the latest TMP version?

I'm guessing it only works for Nightly.


Top
 Profile  
 
PostPosted: Sat Nov 04, 2017 10:41 pm 
Offline

Joined: Wed Dec 04, 2013 2:58 pm
Posts: 9
I see that TMP seems to have broken with today's nightly as well. I see this in the browser console:

NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref] 1 tabmix.js:1235
get isValidWindow chrome://tabmixplus/content/tabmix.js:1235:31
tabmix_initialization_run chrome://tabmixplus/content/tabmix.js:1258:9
TMP_EL_onContentLoaded chrome://tabmixplus/content/tabmix.js:333:9
TMP_EL_handleEvent chrome://tabmixplus/content/tabmix.js:299:9

As it seems to be referencing preference stuff, it might be related to Remove support for extensions having their own prefs file


Top
 Profile  
 
PostPosted: Sun Nov 05, 2017 2:16 am 
Offline
User avatar

Joined: Sun Jun 26, 2016 1:58 pm
Posts: 57
https://bugzilla.mozilla.org/show_bug.c ... 413413#c13
Quote:
Honestly, if you're still using non-bootstrapped extensions, you're going to have much bigger problems soon.

https://bugzilla.mozilla.org/show_bug.c ... 413413#c16
Quote:
Regardless, support for non-bootstrapped legacy extensions is being removed from the add-on manager and other parts of the platform. It's a huge maintenance burden, and we can't continue to support it just for the sake of Thunderbird.

I don't even know if it makes sense to patch Tab Mix Plus.


Top
 Profile  
 
PostPosted: Sun Nov 05, 2017 6:30 pm 
Offline

Joined: Sun Nov 05, 2017 6:07 pm
Posts: 1
Hi onemen and everyone! I'm a new user here but quite a long time Tab Mix Plus user. Thanks onemen and other devs who contribute to this extension!

I wanted to try the latest dev version 171027a1 but the page said it wasn't compatible with my FF version (56.0.2 64-bit). What should I do?

Image


Last edited by makondo on Sun Nov 05, 2017 7:37 pm, edited 2 times in total.
resized image


Top
 Profile  
 
PostPosted: Sun Nov 05, 2017 7:34 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7716
Location: Rocky Mountains
Just install it. Use the 'Download anyway' link on that page.

_________________
•► How to post
•► Troubleshooting
————— ••• ——————
TMP latest dev.build
Win10 ♦ Waterfox
◆ I'm NOT a TMP developer ◆


Top
 Profile  
 
PostPosted: Sun Nov 05, 2017 8:16 pm 
Offline

Joined: Tue Sep 06, 2011 2:18 am
Posts: 22
makondo wrote:
Just install it. Use the 'Download anyway' link on that page.

It won't allow me to either with Firefox 57 Beta 14.
It says it's not compatible.


Top
 Profile  
 
PostPosted: Mon Nov 06, 2017 11:13 am 
Offline

Joined: Tue Oct 18, 2011 10:55 am
Posts: 6
https://wiki.mozilla.org/Add-ons/Firefox57

*Legacy Extension (bootstrapped, overlay, XUL etc) : For Beta Channel, only Signed by Mozilla internally


Top
 Profile  
 
PostPosted: Mon Nov 06, 2017 1:51 pm 
Offline

Joined: Mon Jan 27, 2014 5:32 pm
Posts: 6
Protocol wrote:
makondo wrote:
Just install it. Use the 'Download anyway' link on that page.

It won't allow me to either with Firefox 57 Beta 14.
It says it's not compatible.

Use the developer edition https://www.mozilla.org/en-US/firefox/developer/

and set extensions.legacy.enabled to true.


Top
 Profile  
 
PostPosted: Mon Nov 06, 2017 3:07 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7716
Location: Rocky Mountains
^ Notice my remark was to applyforever with Fx56. Don't know if about:config switch works in 56 release.

_________________
•► How to post
•► Troubleshooting
————— ••• ——————
TMP latest dev.build
Win10 ♦ Waterfox
◆ I'm NOT a TMP developer ◆


Top
 Profile  
 
PostPosted: Mon Nov 06, 2017 5:25 pm 
Offline

Joined: Tue Sep 06, 2011 2:18 am
Posts: 22
notonymous wrote:
Protocol wrote:
makondo wrote:
Just install it. Use the 'Download anyway' link on that page.

It won't allow me to either with Firefox 57 Beta 14.
It says it's not compatible.

Use the developer edition https://www.mozilla.org/en-US/firefox/developer/

and set extensions.legacy.enabled to true.

Thank you.


Top
 Profile  
 
PostPosted: Mon Nov 06, 2017 6:12 pm 
Offline

Joined: Sat Aug 19, 2017 10:01 am
Posts: 1
Larus wrote:

Edit:
I can't select tabs with mouse click, too.


Work around I'm using for that: Try clicking and holding on the tab, then "move" the tab just a bit and it should select. You don't have to move the tab so much that you reorder them, just a slight bit.


Top
 Profile  
 
PostPosted: Tue Nov 07, 2017 2:02 pm 
Offline

Joined: Tue Oct 31, 2017 1:36 pm
Posts: 7
Protocol wrote:
makondo wrote:
Just install it. Use the 'Download anyway' link on that page.

It won't allow me to either with Firefox 57 Beta 14.
It says it's not compatible.

Works with Nightly. Download + install that (you may want to make a different profile: in Windows, right click on the shortcut icon, hit Properties, add paste "C:\Program Files\Nightly\firefox.exe" -no-remote -p in the Target bar). Launch Nightly and paste about:config?filter=extensions.legacy.enabled" in the address bar, and double-left click on extensions.legacy.enabled to toggle it to True. Then download (https://addons.mozilla.org/en-US/firefo ... e.171027a1) 0.5.0.5pre.171027a1 and install it "anyway" to location on your computer, then under File (Alt+f) hit Open file and navigate to the file (has .zpi extension) and Nightly should install it. Then restart the browser.

From https://wiki.mozilla.org/Add-ons/Firefox57: This is what things will look like when Firefox 57 hits release and for each release past that (as far as we can see, things may change).

Nightly builds are here: https://www.mozilla.org/en-US/firefox/nightly/all/
Beta builds are here: https://www.mozilla.org/en-US/firefox/beta/all/
Developer Edition builds are here: https://www.mozilla.org/en-US/firefox/developer/
Release builds are here: https://www.mozilla.org/en-US/firefox/new/
Unbranded builds are here: https://wiki.mozilla.org/Add-ons/Extens ... est_Builds

_________________
Thanks. Grace and peace thru Jesus the Lord.


Top
 Profile  
 
PostPosted: Tue Nov 07, 2017 3:24 pm 
Offline
Admin

Joined: Wed Aug 03, 2005 1:13 am
Posts: 7716
Location: Rocky Mountains
Everyone here,
please read this new sticky.

_________________
•► How to post
•► Troubleshooting
————— ••• ——————
TMP latest dev.build
Win10 ♦ Waterfox
◆ I'm NOT a TMP developer ◆


Top
 Profile  
 
PostPosted: Tue Nov 07, 2017 9:13 pm 
Offline

Joined: Tue Sep 06, 2011 2:18 am
Posts: 22
If I use the modified version of Firefox 57+ from here, can I use the legacy version of Tab Mix Plus or the development version? It's not real clear. It says I can use the development version of Tab Mix Plus with the Nightly Firefox, but which version of Tab Mix Plus can I use with the modified version of Firefox?


Top
 Profile  
 
PostPosted: Tue Nov 14, 2017 11:08 am 
Offline
User avatar

Joined: Sun Jun 26, 2016 1:58 pm
Posts: 57
@Protocol I would use development version, it should support both FF57 and FF58.


Top
 Profile  
 
PostPosted: Tue Nov 14, 2017 8:07 pm 
Offline

Joined: Mon Jan 27, 2014 5:32 pm
Posts: 6
Using Dev Edition 58.0b3 buildID 20171114032831
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

with TMP 0.5.0.5pre.171027a1 is currently broken (cannot select tabs in the tab bar). The following message appears in the console:
Code:
TypeError: tabstrip is undefined[Learn More]  scrollbox.xml:43:11
   tabmix-right-scrollBox_XBL_Constructor chrome://tabmixplus/content/tab/scrollbox.xml:43:11


Cheers ...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 461 posts ]  Go to page Previous  1 ... 20, 21, 22, 23, 24  Next

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group